CentOS安装Python

参考文献:https://blog.csdn.net/lovefengruoqing/article/details/79284573

参考文献2(来自Segmentfault):https://segmentfault.com/a/1190000009922582

遇到两个报错:

1、gcc错误,内存不足导致,于是干掉Hadoop等进程

2、编译错误,重新完全编译,选择3.6.1安装包编译

centos7自带有python,但是确实python2版本的python,如果你想安装个python3怎么办呢?难道要从github上把源码clone下来进行编译安装么?这么做对于我们个人用户来说,完全没必要嘛。

1.首先,你要知道系统现在的python的位置在哪儿:

[root@root ~]# whereis pythonpython: /usr/bin/python2.7 /usr/bin/python /usr/lib/python2.7 /usr/lib64/python2.7 /etc/python /usr/include/python2.7 /usr/share/man/man1/python.1.gz

可以知道我们的python在 /usr/bin目录中

[root@root ~]# cd /usr/bin/[root@root bin]# ll python*lrwxrwxrwx. 1 root root    7 2月  7 09:30 python -> python2

lrwxrwxrwx. 1 root root    9 2月  7 09:30 python2 -> python2.7-rwxr-xr-x. 1 root root 7136 8月  4 2017 python2.7

可以看到,python指向的是python2,python2指向的是python2.7,因此我们可以装个python3,然后将python指向python3,然后python2指向python2.7,那么两个版本的python就能共存了。

2.因为我们要安装python3,所以要先安装相关包,用于下载编译python3:

yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gcc make 

运行了以上命令以后,就安装了编译python3所用到的相关依赖

3.默认的,centos7也没有安装pip,不知道是不是因为我安装软件的时候选择的是最小安装的模式。

#运行这个命令添加epel扩展源yum -y install epel-release#安装pipyum install python-pip

4.用pip装wget

pip install wget

5.用wget下载python3的源码包

wget https://www.python.org/ftp/python/3.6.4/Python-3.6.4.tar.xz

6.编译python3源码包

#解压xz -d Python-3.6.4.tar.xztar -xf Python-3.6.4.tar#进入解压后的目录,依次执行下面命令进行手动编译./configure prefix=/usr/local/python3.6

make && make install

如果最后没提示出错,就代表正确安装了,在/usr/local/目录下就会有python3目录

7.添加软链接

#将原来的链接备份mv /usr/bin/python /usr/bin/python.bak#添加python3的软链接ln -s /usr/local/python3.6/bin/python3.6 /usr/bin/python#测试是否安装成功了python -V

8.更改yum配置,因为其要用到python2才能执行,否则会导致yum不能正常使用

vi /usr/bin/yum

把#! /usr/bin/python修改为#! /usr/bin/python2

vi /usr/libexec/urlgrabber-ext-down

把#! /usr/bin/python 修改为#! /usr/bin/python2

文章来源于互联网,如有雷同请联系站长删除:CentOS安装Python3

发表评论