之前有同学遇到装CentOS7.0-1406版本发生的各种问题,有时间就整理了部分问题汇总,希望有所帮助


1、Yum安装依赖问题

无论怎么安装都会不成功情况,还有报错:

[root@linuxprobe~]# rpm -ivh yum-fastestmirror-1.1.26-11.el6.centos.noarch.rpm

error: Failed dependencies:

yum >= 3.0 is needed by yum-fastestmirror-1.1.26-11.el6.centos.noarch

[root@linuxprobe~]# rpm -ivh yum-3.2.27-14.el6.centos.noarch.rpm

error: Failed dependencies:

yum-fastestmirror is needed by yum-3.2.27-14.el6.centos.noarch

解决方法:(出现yum问题的同学可尝试一下)

[root@localhost rpm]# rpm -ivh yum-3.2.27-14.el6.centos.noarch.rpm yum-fastestmirror-1.1.26-11.el6.centos.noarch.rpm


2、yum install mysql-server没有可用包的问题

[azq@localhost ~]$ sudo yum install mysql-server

已加载插件:fastestmirror, langpacks

Loading mirror speeds from cached hostfile

  • base: mirrors.163.com

  • extras: mirrors.163.com

  • updates: centos.ustc.edu.cn

没有可用软件包 mysql-server。

错误:无须任何处理

解决方法:

wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm

正在解析主机 repo.mysql.com (repo.mysql.com)… 23.4.241.142

正在连接 repo.mysql.com (repo.mysql.com)|23.4.241.142|:80… 已连接。

已发出 HTTP 请求,正在等待回应… 200 OK

长度:6140 (6.0K) [application/x-redhat-package-manager]

正在保存至: “mysql-community-release-el7-5.noarch.rpm”

100%[>] 6,140       –.-K/s 用时 0s

(467 MB/s) – 已保存 “MySQL-community-release-el7-5.noarch.rpm” [6140/6140])

ls

mysql-community-release-el7-5.noarch.rpm

rpm -ivh mysql-community-release-el7-5.noarch.rpm

准备中…                          ################################# [100%]

正在升级/安装…

1:mysql-community-release-el7-5    ################################# [100%]

ps:如果出现can’t create transaction lock on /var/lib/rpm/.rpm.lock 错误

错误原因:权限问题

解决方法:在终端输入“su”和密码,登录root,以root身份登录就不会有提示

ls -1 /etc/yum.repos.d/mysql-community*

/etc/yum.repos.d/mysql-community.repo

/etc/yum.repos.d/mysql-community-source.repo

yum install mysql-server


3、yum报错Error: Cannot retrieve metalink for repository: epel

运行yum报错Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

今天给Centos通过rpm -Uvh装了个epel的扩展后,执行yum就开始报错:

Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

在网上查了查,解决办法都是编辑/etc/yum.repos.d/epel.repo,把基础的恢复,镜像的地址注释掉

#baseurl

mirrorlist

改成:

baseurl

#mirrorlist


4、解决CentOS安装mysql*.rpm提示conflicts with file from package

CentOS 6.5下安装MySQL 5.6

解压文件:tar xvf MySQL-5.6.19-1.linux_glibc2.5.x86_64.rpm-bundle.tar

释放出以下文件:

MySQL-embedded-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-devel-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-shared-compat-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-shared-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-server-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-client-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-test-5.6.19-1.linux_glibc2.5.x86_64.rpm

如下图:

通过lss查看文件名都是红色的,说明文件的访问权限比较高,我们用命令“chmod 777 ./*”将权限改的低一点,

777应该是最低的权限,相当Windows下everyone可读可写可执行,也就是完全控制。

具体可以看一下:chmod 755和chmod 4755的区别

这里只用到了:

MySQL-server-5.6.19-1.linux_glibc2.5.x86_64.rpm

MySQL-client-5.6.19-1.linux_glibc2.5.x86_64.rpm

使用以下命令安装:

rpm -ivh MySQL-server-5.6.19-1.linux_glibc2.5.x86_64.rpm

错误提示如下:

[plain] view plain copy    在CODE上查看代码片派生到我的代码片

Preparing…                ########################################### [100%]

file /usr/share/mysql/charsets/README from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/danish/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/dutch/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/english/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/estonian/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

file /usr/share/mysql/french/errmsg.sys from install of MySQL-server-5.6.19-1.linux_glibc2.5.x86_64 conflicts with file from package mysql-libs-5.1.71-1.el6.x86_64

… …

看到“conflicts”,是产生冲突了,文件“/usr/share/mysql/charsets/*”

需要MySQL-server-5.6.19-1.linux_glibc2.5.x86_64版本的,

而系统已经存在mysql-libs-5.1.71-1.el6.x86_64版本的!

解决办法:

执行以下命令,删除mysql-libs-5.1.71-1.el6.x86_64:

yum -y remove mysql-libs-5.1.71*

再执行以下命令安装MySQL:

rpm -ivh MySQL-server-5.6.19-1.linux_glibc2.5.x86_64.rpm

一切Ok,安装成功了。


5、解决连接MySQL错误:Can’t connect to MySQL server (10060)

使用图形界面管理工具Navicat for MySQL连接Mysql数据库时

提示错误:Can’t connect to MySQL server (10060)

问题原因:

导致些问题可能有以下几个原因:

1、网络不通;

2、服务未启动;

3、防火墙端口未开放;

解决方法:

启动服务:

service mysqld start;

经过分析,我遇到的这个问题是防火墙导致的!

开放防火墙端口

添加需要监听的端口

/sbin/iptables -I INPUT -p tcp –dport 3306 -j ACCEPT

保存设置

/etc/init.d/iptables save

查看状态

/etc/init.d/iptables status

临时关闭防火墙服务

service iptables stop

开启防火墙服务

service iptables start

开机不再启动防火墙服务

chkconfig iptables off

注意:

此文档适用服务器环境为:CentOS 6.5  MySQL 5.6

如果是Java程序连接不上数据库,

请参考:Connections could not be acquired from the underlying database


6、解决VMWare克隆CentOS后虚拟网卡无法启动

大家在学习centos时,会建立centos虚拟模板,然后我们会创建克隆,

但克隆会查看启动过程会发现网卡无法启动,此时我们需要如下操作。

vi  /etc/sysconfig/network-scripts/ifcfg-eth0

#vi编辑器编辑这个文件。

#按i进入编辑模式,删除HWADDR和UUID这两行。然后按esc退出编辑模式,按:wq保存并退出。

#清空以下文件

/etc/udev/rules.d/70-persistent-net.rules

#重启

reboot

#启动以后,我们执行ifup eth0可以成功启动网卡说明修改成功


未完待续……

文章来源于互联网,如有雷同请联系站长删除:CentOS安装各类程序时问题汇总

发表评论