在centos上安装Python会遇到的问题

我们平常开发使用的Python版本可能是Python3但是centos的yum等其他软件需要依赖Python2.7.5版本才能正常工作,为了解决Python的版本冲突问题所以我们需要通过安装pyenv来对Python进行版本管理,既能保证依赖Python2的程序软件正常运行,又能保证我们可以正常的使用Python3来开发程序。

通过git安装pyenv

首先我们的centos需要先支持git
通过yum install git来安装git。

我们先通过git克隆pyenv到本地。
git clone git://github.com/yyuu/pyenv.git ~/.pyenv
然后添加配置来启用pyenv

$ echo 'export PYENV_ROOT="$HOME/.pyenv"' >> ~/.bashrc
$ echo 'export PATH="$PYENV_ROOT/bin:$PATH"' >> ~/.bashrc
$ echo 'eval "$(pyenv init -)"' >> ~/.bashrc
$ exec $SHELL -l

一行一行的输入上面的配置。

之后输入
pyenv install --list
查看我们可以安装的Python的版本

可安装的Python版本

pyenv会提供一个列表告诉我们有哪些Python的版本是可以安装的。

在centos下通过pyenv安装Python之前最好把Python需要的依赖库提前安装好,因为没有通过yum来安装可能有些依赖不会自动安装上。

sudo yum install gcc
sudo yum install readline readline-devel readline-static
sudo yum install openssl openssl-devel openssl-static
sudo yum install sqlite-devel
sudo yum install bzip2-devel bzip2-libs

安装最新的Python3.5.1版本

通过这条命令让pyenv自动安装3.5.1版本的python。
pyenv install 3.5.1 -v
刷新一下pyenv
pyenv rehash
查看安装的python版本

# pyenv versions
* system (set by /root/.pyenv/version)
  3.5.1

但是当我们输入python的时候显示的还是2.7.5的版本

python

将3.5.1设置为全局版本。

pyenv global 3.5.1

然后我们就看到python启动3.5.1的版本了。

python

文章来源于互联网,如有雷同请联系站长删除:在centos上安装Python版本管理器

发表评论