Monocle 的3.0版本出了 beta版,相对之前alpha最明显的变化就是有多了几个依赖包,导致我在CentOS安装时很不顺利,折腾了很久时间。

这里只记录几个关键点

  1. Monocle3 依赖一个sf包,sf需要系统有一个GDAL库。CentOS的GDAL是1.11版本,最新版是GDAL 3.0.0,但是我发现2.1.3就够用了
  2. GDAL 2.1.3依赖于PROJ.4, 我测试了4.8.0版本能够使用
  3. 安装PROJ.4后,还需要将/usr/loca/lib里的libproj.solibproj.so.0软连接到/usr/local/lib64中,这是因为我是64位系统
  4. 此外,sf还依赖于geos-devel

能够顺利安装sf包,基本上Monocle 3的beta版本也就没有问题了。

文章来源于互联网,如有雷同请联系站长删除:「Debug R」在CentOS上安装monocle3的记录

发表评论