在更新或者安装 docker 容器的时候,提示下面的错误:

Problem: package docker-ce-3:19.03.13-3.el7.x86_64 requires containerd.io >= 1.2.2-3

上面的问题如何解决。

解决

根据提示的内容,上面已经说得比较明确了。

就是需要使用 containerd.io 的版本要升级下。

你可以访问 docker 官方的链接有关 CentOS 的安装部分:

Install Docker Engine on CentOS

首先你需要设置仓库:

sudo yum install -y yum-utils sudo yum-config-manager     –add-repo     https://download.docker.com/linux/centos/docker-ce.repo

然后执行命令

sudoyuminstalldocker-cedocker-ce-clicontainerd.io

就可以解决上面的问题了。

https://www.ossez.com/t/centos-8-docker-containerd-io-1-2-2-3/548

文章来源于互联网,如有雷同请联系站长删除:CentOS 8 安装 docker 报错 containerd.io >= 1.2.2-3

发表评论