Centos系统自带的php版本很低,如果我们需要使用高版os php本的php,可以不用编译安装,直接用yum安装会非常省时省力。

  1. 检查当前是否有安装php
rpm -qa|grep php 

如果有安装PHP,那么请先删除这些安装包:

 yum remove php*
  1. 安装php源

Centos 5 安装php源:

rpm -ivh http://mirror.webtatic.com/yum/el5/latest.rpm

CentOs 6 安装php源:

rpm -ivh http://mirror.webtatic.com/yum/el6/latest.rpm

CentOs 7 安装php源和epel扩展源:

rpm -ivh https://mirror.webtatic.com/yum/el7/epel-release.rpmrpm -ivh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
  1. 现在开始安装php

安装php5.5的基本安装包:

yum install php55w php55w-gd php55w-mbstring php55w-mysql php55w-fpm

安装php5.6的基本安装包:

yum install php56w php55w-gd php56w-mbstring php56w-mysql php56w-fpm

安装php7.0的基本安装包:

yum install php70w php70w-gd php70w-mbstring php70w-mysql php70w-fpm

安装完成php之后需要重启apache:

service httpd restart
  1. 测试网页

我安装的php7.0,就拿php7.0写个网页测试一下

vim /var/www/html/index.php

文章来源于互联网,如有雷同请联系站长删除:Centos安装php高版本

发表评论