安装pyspider

1 windows安装

pyspider的安装非常简单,一般直接pip install pyspider就好啦O(∩_∩)O*
注意: “ 最好是安装python3.7以下的版本,python3.7及以后运行pyspider会由于关键字的原因报错,然后我又把我的py3.7换成了py3.6,终于好了”
报错1:

image.png

解决办法:直接到这个网址https://www.lfd.uci.edu/~gohlke/pythonlibs/#pycurl
(1)去下载对应版本的pycurl,比如我是py3.6的下载 [pycurl-7.43.0.3-cp36-cp36m-win_amd64.whl]
(2)然后cmd到改文件对应目录下 pip3 install pycurl-7.43.0.3-cp36-cp36m-win_amd64.whl
(3)安装成功之后再次 pip3 install pyspider
ok! 成功!
报错2:
命令行运行pyspider的时候报错如下:

image.png

这是WsgiDAV发布了版本 pre-release 3.x导致的可以参考这篇https://blog.csdn.net/SiHann/article/details/88239892
,只要把版本降下来就好了。
将wsgidav替换为2.4.1,在命令行下运行
python -m pip install wsgidav==2.4.1
这下终于完成了!

image.png

文章来源于互联网,如有雷同请联系站长删除:pyspider 安装以及报错解决

发表评论