待安装系统环境

系统:macOS 10.13.2
依赖:

  • 1、已经安装了Python 2.7.10
  • 2、pip 9.0.1

查看本机scrapy版本的方法

在命令行输入 scrapy version -v 如果是未安装的话,会提示 No such file or directory

安装

这里我们推荐使用 python包管理器 pip 进行安装,

如果未安装pip,或者不知道怎么安装 pip 可以查看上一篇文章
2018最新Mac安装/卸载pip教程 https://www.jianshu.com/p/66d85c06238c

在命令行输入 pip install scrapy 便自动安装了。

到这里,别急着高新,有可能马上报错呢,如果你的 six 库版本太低了,就会出现下面的报错。

Found existing installation: six 1.4.1

不过也别急,升级一下就好。

升级 six 方法

在命令行输入
sudo pip install Scrapy --upgrade --ignore-installed six

安装最后 如果出现 Successfully installed 说明安装完成了。

这是再查看下scrapy版本 就会出现下面的 提示了

文章来源于互联网,如有雷同请联系站长删除:2018最新Mac上安装scrapy教程,解决Found existing installation: six报错

发表评论