导入Flask库出现了问题:安装了flask,却还是在import的时候报错了

    毕竟新手,只能去找一些教程,发现是因为使用的flask框架和当前工程下的python版本不匹配导致的,于是,修改了python版本,然后就run通了~~
  • 首先
    我们一般都是使用命令sudo pip install flask来装的flask库,所以都是以终端识别的python版本为准,安装的对应版本的flask库,所以可以用flask —version来看当前版本:

    图1:查看当前flask版本
  • 查到flask对应的是python 2.7.10的,而我的pystorm里自带的是2.6.9的,所以肯定是import失败的~
  • 于是乎
    修改我pycharm里python的版本:
    Preferences->Project Interpreter,修改python版本

    图2:找到Preferences

    图3:找到我的python是2.6.9

    图4:切换我的python到2.7.10

文章来源于互联网,如有雷同请联系站长删除:import Flask报错

发表评论