yum 安装软件使用起来非常方便,它可以自动解决 rmp 包之间的依赖关系,比如我们安装 rpm 包 A,但包 A 需要包 B 的库,包 B 又需要包 C,包 C 又需要包 D,如果用 rpm -vihA,我们就还需要安装包 B、C、D,但如果我们用 yum-y install A 的话,系统会自动将 A 需要的软件包 B、C、D 全安装上,这非常方便。

反之yum remove 删除一个软件的时候也会删除对该软件具有以来关系的包

通过这手一抖,我终于对依赖于 centos 系统上依赖于 python 的软件究竟有多少有了生动形象而具体的概念

在此特别提示大家慎用 yum remove 等操作

实践经历:

部署数聚蜂巢安装mysql报错:

TASK [mysql : install mysql] ********************************************************************************************************************************************************
Friday 09 August 2019 11:49:00 +0800 (0:00:19.445) 1:33:05.479 *********
fatal: [10.238.46.83]: FAILED! => changed=false
changes:
installed:

  • mysql-community-common-5.7.24
  • mysql-community-libs-5.7.24
  • mysql-community-libs-compat-5.7.24
  • mysql-community-client-5.7.24
  • mysql-community-server-5.7.24
  • percona-xtrabackup-24
  • xinetd
    msg: |-
    Error: Package: akonadi-mysql-1.9.2-4.el7.x86_64 (@anaconda)
    Requires: mariadb-server
    Removing: 1:mariadb-server-5.5.56-2.el7.x86_64 (@anaconda)
    mariadb-server = 1:5.5.56-2.el7
    Obsoleted By: mysql-community-server-5.7.24-1.el7.x86_64 (orchsym-local)
    Not found
    Updated By: 1:mariadb-server-5.5.60-1.el7_5.x86_64 (base)
    mariadb-server = 1:5.5.60-1.el7_5
    rc: 1
    results:
  • MySQL-python-1.2.5-1.el7.x86_64 providing MySQL-python is already installed

问题分析和处理:
which mysql

[root@cnj02143 orchsym-installer]# /usr/bin/mysql –version
/usr/bin/mysql Ver 15.1 Distrib 5.5.56-MariaDB, for Linux (x86_64) using readline 5.1

[root@cnj02143 orchsym-installer]# rpm -qa|grep -i maria
mariadb-server-5.5.56-2.el7.x86_64
mariadb-5.5.56-2.el7.x86_64
mariadb-libs-5.5.56-2.el7.x86_64

可以看到本机已经有了低版本的mysql 导致部署失败,需要卸载之:

rpm -e –nodeps mariadb-server-5.5.56-2.el7.x86_64 mariadb-5.5.56-2.el7.x86_64 mariadb-libs-5.5.56-2.el7.x86_64

yum remove 会导致依赖包被卸载 所以不要使用

文章来源于互联网,如有雷同请联系站长删除:2019-08-21 部署数聚蜂巢时由于系统自带mysql导致部署mysql时报错

发表评论