1. Command “python setup.py egg_info” failed with error code 1 in /private/var/folders/5z/rdw4jbs11b5168_0wmkg73w80000gn/T/pip-install-Y5Snd2/twisted/
Collecting channels==1.1.8
  Using cached https://files.pythonhosted.org/packages/7a/a6/5a3420c0b93e127fd5b22eaf4155b8c76eb7c404eeac78f4f0816fab97ce/channels-1.1.8-py2.py3-none-any.whl
Collecting daphne~=1.3 (from channels==1.1.8)
  Using cached https://files.pythonhosted.org/packages/b4/e3/65ba9a2044627826eae52f07a9013f82339bb88917aadf69c702e0e51eea/daphne-1.4.2-py2.py3-none-any.whl
Collecting asgiref~=1.1 (from channels==1.1.8)
  Using cached https://files.pythonhosted.org/packages/ee/6d/67f79a9567de5ba4419c3e8d39622bed0d974d704075d09df765b5ddb5ce/asgiref-1.1.2-py2.py3-none-any.whl
Requirement already satisfied: Django>=1.8 in ./.virtualenvs/dev_system/lib/python2.7/site-packages (from channels==1.1.8) (1.11.9)
Collecting twisted>=17.1 (from daphne~=1.3->channels==1.1.8)
  Using cached https://files.pythonhosted.org/packages/90/50/4c315ce5d119f67189d1819629cae7908ca0b0a6c572980df5cc6942bc22/Twisted-18.7.0.tar.bz2
    Complete output from command python setup.py egg_info:
    Download error on https://pypi.org/simple/incremental/: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590) -- Some packages may not be found!
    Couldn't find index page for 'incremental' (maybe misspelled?)
    Download error on https://pypi.org/simple/: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590) -- Some packages may not be found!
    No local packages or working download links found for incremental>=16.10.1
    Traceback (most recent call last):
      File "", line 1, in 
      File "/private/var/folders/5z/rdw4jbs11b5168_0wmkg73w80000gn/T/pip-install-Y5Snd2/twisted/setup.py", line 20, in 
        setuptools.setup(**_setup["getSetupArgs"]())
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/setuptools/__init__.py", line 139, in setup
        _install_setup_requires(attrs)
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/setuptools/__init__.py", line 134, in _install_setup_requires
        dist.fetch_build_eggs(dist.setup_requires)
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/setuptools/dist.py", line 514, in fetch_build_eggs
        replace_conflicting=True,
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/pkg_resources/__init__.py", line 777, in resolve
        replace_conflicting=replace_conflicting
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1060, in best_match
        return self.obtain(req, installer)
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1072, in obtain
        return installer(requirement)
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/setuptools/dist.py", line 581, in fetch_build_egg
        return cmd.easy_install(req)
      File "/Users/admin/.virtualenvs/dev_system/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 670, in easy_install
        raise DistutilsError(msg)
    distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('incremental>=16.10.1')
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/5z/rdw4jbs11b5168_0wmkg73w80000gn/T/pip-install-Y5Snd2/twisted/

解决方案:

sudo pip install incremental

  1. python3.6 failing due to ssl module not available
pip installs inside virtual environment with python3.6 failing due to ssl module not available

解决方案:

brew install openssl
brew unlink openssl && brew link openssl –force

vim Python3.6.1/Module/Setup.dist (line 209)
SSL=/usr/local/opt/openssl
_ssl _ssl.c
-DUSE_SSL -I(SSL)/include -I(SSL)/include/openssl
-L$(SSL)/lib -lssl -lcrypto

export CFLAGS=”-I$(brew –prefix openssl)/include”
export LDFLAGS=”-L$(brew –prefix openssl)/lib”

./configure && make && make install

  1. pycharm 安装第三方库报错:AttributeError: ‘module’ object has no attribute ‘main’
AttributeError: 'module' object has no attribute 'main'

解决方案:

找到pycharm 目录下的 helperpackaging_tool.py 文件
将其中 pip.main() 改为 pip_main()

  1. not found mysql_config
Error not found mysql_config

解决方案:

brew install mysql-connector-c
pip install mysqlclient

文章来源于互联网,如有雷同请联系站长删除:mac安装模块报错解决指南

发表评论