因为开发需要Python2.7版本,然而服务器是CentOS6.9,默认安装的是Python2.6,所以需要升级到Python2.7,版本如图:

当前版本

下面正式开始:

一 【升级到Python2.7】

1.下载python2.7源码,解压

wget https://www.python.org/ftp/python/2.7.14/Python-2.7.14.tar.xz
unxz Python-2.7.14.tar.xz
tar -vxf Python-2.7.14.tar
cd Python-2.7.14

2.configure

./configure --enable-shared --enable-loadable-sqlite-extensions --with-zlib

其中–enable-loadable-sqlite-extensions是sqlite的扩展,如果需要使用的话则带上这个选项。

3.编译前修改配置。

vi ./Modules/Setup

找到 #zlib zlibmodule.c -I(prefix)/include -L(exec_prefix)/lib -lz 这行,去掉最前面的#号注释并保存,然后进行编译和安装

4.make 和 make install

make && make install

5.对Python2.6进行备份,然后为Python2.7创建软链接,使python命令指向Python2.7

mv /usr/bin/python /usr/bin/python2.6
ln -s /usr/local/bin/python2.7 /usr/bin/python

6.升级会使yum命令版本不兼容而报错

yum

报错如图:

yum版本不兼容

7.修改配置,解决yum版本不兼容的问题

vi /usr/bin/yum

编辑/usr/bin/yum,将第一行的#!/usr/bin/python修改成之前备份的 #!/usr/bin/python2.6
现在执行yum命令已经不会出现之前的报错信息了

8.查看python版本,也是由于版本不兼容而报错

python -V

报错如图:

python版本不兼容

9.解决python版本不兼容问题

vi /etc/ld.so.conf

编辑 /etc/ld.so.conf 文件,尾部新加入一行 /usr/local/lib 并保存,然后执行:

/sbin/ldconfig  
/sbin/ldconfig -v

恭喜!python版本升级已经完成。如图:

Python2.7版本

二 【安装pip】

1.下载pip

wget https://bootstrap.pypa.io/get-pip.py

2.然后安装

python get-pip.py

3.查找pip的位置

whereis pip

4.找到pip2.7的路径,为其创建软链作为系统默认的启动版本

ln -s /usr/local/bin/pip2.7 /usr/bin/pip

pip安装完毕,现在可以用它下载安装各种包了

三 【安装MySQL的扩展包 MySQLdb】

1.首先要安装mysql-devel

yum install mysql-devel

如果没有安装mysql-devel而直接 pip install MySQL-python 会报错

没有安装mysql-devel会报错

2.然后使用pip安装MySQLdb

pip install MySQL-python

恭喜!MySQLdb已经安装成功,如图:

MySQLdb已安装

文章来源于互联网,如有雷同请联系站长删除:CentOS6.X升级Python2.6到Python2.7并安装pip,MySQLdb

发表评论