spacy的安装出现Creating a shortcut link for ‘en’ didn’t work问题以及 from spacy.en import English报错

安装spacy

pip install spacy

模块下载


  • 问题1:

Download successful
Creating a shortcut link for ‘en’ didn’t work (maybe you don’t have
admin permissions?), but you can still load the model via its full
package name:

  • 解决方法:
    Windows上需要使用管理员权限打开Anaconda Prompt。然后使用命令

python -m spacy download en

成功安装

使用

  • 问题2:
    from spacy.en import English报错

    问题2
  • 解决方法:

from spacy.lang.en import English

问题2解决

原因是因为spacy2.0版本的模块路径(spacy/lang/en);而spacy1.9版本不会报这种错误。

参考文献

官方文档Models & Languages

文章来源于互联网,如有雷同请联系站长删除:spacy的安装出现Creating a shortcut link for ‘en’ didn’t work问题以及 from spacy.en import English报错

发表评论