今天我想用pip下载一个dlib模块,就输入了如下指令

pip install dlib

然后就报错了,一屏的错!

在这里插入图片描述

我当时就蒙了,但是经验告诉我不要慌,那么长的字都是废话,终端就喜欢恶搞,只看最后一两行才是关键,最后提示:

在这里插入图片描述

看见我画横线的地方了吗?😬上网查,原来很多人也有这个问题,是因为pip的版本太低,需要升级,我又查怎么升级pip,哦指令在这里

python -m pip install --upgrade pip

如果正常下载,Successfully就成功了!(我没有正常下载,所以我没图,这图是别人的)

在这里插入图片描述

结果我是成功了,然后重新使用pip下载dlib,结果emmm……

在这里插入图片描述

找不到pip,我慌了!😱还以为是环境变量,结果查看没有问题

🔥EXO ME💢

再次上网查,越在这种情况下越要坚信度娘!

哦,还要指令啊,再把下面的输入

python -m ensurepip
.

看起来一切正常,再试一次下载dlib

结果还报错!刷刷的汗就流下来了……不会崩了吧?我自己想~

在这里插入图片描述

又搜索,还有指令😱😱
指令如下,是重新安装pip的

easy_install pip

你再试试pip

在这里插入图片描述

吁~~~~成了
但是版本还没有变,再输入python -m pip install --upgrade pip

在这里插入图片描述

就成了,下载dlib去喽!

哎对了,为什么不点赞关注?


感谢这些帮助我的人写的博文:
https://blog.csdn.net/wuyepiaoxue789/article/details/84033651
.
https://blog.csdn.net/douniwan007009/article/details/81463958
.
https://blog.csdn.net/read22580/article/details/78911437
.
https://jingyan.baidu.com/album/154b4631342f1528ca8f41ee.html?picindex=4

文章来源于互联网,如有雷同请联系站长删除:pip无法下载模块报错?看这篇就够了!

发表评论